PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Keine Bankverbindung unter Windows Mobile 6



aselle
26.07.2007, 16:06:45
Hallo allerseits,

mehrere Kunden die Windows Mobile 6 einsetzen haben inzwischen von Problemen beim Verbindungsaufbau zur Bank berichtet. Es wird die Fehlermeldung "Verbindung zur Bank nicht möglich" angezeigt. Das Problem betrifft nicht alle Banken, sondern nur die Sparkassen in Westfalen (DNS-Name hbci-pintan-wf.s-hbci.de), Hessen (DNS-Name hbci-pintan-he.s-hbci.de) und ein paar in Bayern (DNS-Name hbci-pintan-by.s-hbci.de).

(Achtung jetzt wird's sehr technisch. Problemlösung findet Ihr weiter unten)

Bei genauer Untersuchung habe ich herausfinden können, dass das Problem mit der neuen AES-SSL-Implementierung in Windows Mobile 6 zu tun hat. Bei manchen Banken scheint eine AES-SSL-Verbindung zu funktionieren, bei anderen wieder nicht. Die problematischen Systeme sind die einzigen getesteten Server welche die so genannten SSL Cipher-Suites DHE-RSA-AES256-SHA und DHE-RSA-AES128-SHA (neben vielen anderen Cipher-Suites) unterstützen. Und genau das ist vermutlich das Problem. Mit dieser ganz speziellen SSL-Cipher-Suite kommt Windows Mobile 6 nicht zurecht.

Ich glaube kaum, dass ich die Rechenzentren davon überzeugen kann, diese beiden SSL-Cipher-Suites einfach zu deaktivieren. Was für die eigentlich kein Problem wäre, es sind ja noch viele andere da, auch welche mit AES Verschlüsselung. Ich werd es dennoch versuchen - in der kleinen Hoffnung dort jemanden zu finden der überhaupt Ahnung von SSL-Cipher-Suites und deren Implikationen hat.

(Jetzt kommt die Lösung)

Bleibt noch die Alternative die SSL-AES-Verschlüsselung in Windows Mobile 6 selbst zu deaktivieren. Auch das ist nicht schlimm. Unter Windows Mobile 5 gab es diese sowieso nicht und es sind noch etliche andere starke SSL-Verschlüsselungen im Angebot. Eigentlich geht das ganz leicht, man braucht nur einen Registry Editor dafür. Dann kann man folgende Einträge ändern:

[HKEY_LOCAL_MACHINE\Comm\SecurityProviders\SCHANNEL \Ciphers\AES 128/128]
Enabled=0

[HKEY_LOCAL_MACHINE\Comm\SecurityProviders\SCHANNEL \Ciphers\AES 256/256]
Enabled=0

Der Enabled-Wert steht normalerweise auf 196. Wird er auf 0 gesetzt ist die entsprechende Verschlüssel deaktiviert und es wird auf eine andere Verschlüsselung ausgewichen. Zumindest im Emulator hat das geklappt. Wichtig: Nach der Änderung alle betroffenen Programme (IE, FinPocket, ...) komplett beenden und neu starten.

Ich hoffe es findet sich noch eine elegantere Lösung...

Promaster
21.08.2007, 12:49:37
Ist das Problem auch in euerer neuen Version 3.0 enthalten, oder kann man dort umschalten ohne Registry editor?

aselle
21.08.2007, 12:50:53
Das Problem ist in Windows Mobile 6 selbst und betrifft somit alle FinPocket, FinPhone und Subsembly Banking Versionen.

Promaster
21.08.2007, 12:56:27
wäre es da nicht sinnvoll eine option in euer Programm einzubauen. Schließlich steht bei euch auf der Seite: gesetet mit WM6. oder wenigstens die Fehlermeldung deutlicher zu kennzeichen.

PS: habs noch die 2.61er version.
Mit dem Registry entrag klappt es jetzt wunderbar (für die Nassausche Sparkasse in Hessen)

aselle
21.08.2007, 13:06:27
Im Programm selbst in der Registry so etwas abzuschalten halte ich für "unschön" um es vorsichtig zu formulieren. Aber irgend etwas sollte ich mir einfallen lassen. Ich hoffe immer noch, dass ich das Rechenzentrum dazu bewegen kann hier etws zu ändern.

Zum Thema getestet mit WM6: Haben wir ja, und festgestellt, dass es Probleme gibt :-)

Es betrifft auch nur die genannten Sparkassen, also nur einen kleinen Teil unserer Kunden. Bei allen anderen Sparkassen und Banken funktioniert es unter WM6 auch ohne Registry-Hack problemlos.

Promaster
21.08.2007, 13:12:55
hoffe da kommt nochwas, da ich öfter die Image wechsle, das ich nicht stäntig noch daran denken muss.
Trozdem super Programm was Ihr das habt.